PHP verzió beállítás – MultiPHP Manager

A legújabb PHP verzióra van szükséged az oldalad működéséhez? Nem probléma, domainenként tudod ezt állítani a cPanelen a MultiPHP Manager menüpontban.

Jó tudni!

A tárhelyeinken alapbeállításként alkalmazott PHP verzió nem a legmagasabb. Ez azért van így, mert sok weboldal típus nem indul el a legfrissebb PHP verzióval. Azonban vannak oldalak, amelyeknek viszont szüksége van a legfrissebb PHP verzióra, sok weboldal program csak így hajlandó működni. Ha lehet, mindenképpen ajánlott a magasabb PHP verzió használata!

Miért jó, ha egy weboldal a legfrissebb PHP verziót használja?

Minden PHP verzió váltáskor javul a biztonság és az oldalak gyorsasága is. Összehasonlítva pl. a WordPress betöltődési sebessége legalább harmadával jobb a 7.0-ás PHP verzióval, mint az 5.6-os verzión. Biztonsági szempontból pedig az egyes verziókon belül akár több ezer biztonsági rést foltoznak be, így hatványozottan több esélyt adunk a hackereknek az oldalunk feltörésére, ha régi PHP verziót használunk.

PHP verzió beállítása a cPanelen

Lépj be a cPanelre, majd válaszd a Szoftver->MultiPHP Manager menüpontot*

*előfordulhat, hogy olyan szerveren van a tárhelyed, ahol nincs MultiPHP Manager menüpont. Ilyen esetben a Select PHP Version linken tudod elérni a PHP verzió váltást. Ebben az esetben csak globálisan tudod állítani a PHP verziót, nem domainenként.

Válaszd ki a domain(eket) amelyhez tartozó PHP verziót meg szeretnéd változtatni, és válaszd ki a verziót. FIGYELEM! Csak az “ea” verziók működnek! Ezután kattints az Alkalmazás gombra.

Ellenőrizd az oldaladat, hogy működik-e minden funkciója. Ha hibát tapasztalsz, akkor lehetséges, hogy az oldalad valamely kiegészítője nem kompatibilis az aktuális PHP verzióval. Ekkor a fenti módon állítsd vissza a korábbi verziót, frissítsd a kiegészítőt, majd ismét próbáld meg a friss PHP verziót beállítani.

Jó tudni!

A szerver alapértelmezett PHP verziójára úgy tudod visszaállítani a domaint, ha a listából az “Inherit”-et választod ki.

A MultiPHP Manager a beállított domain könyvtárjában létrehoz egy .htaccess fájlt (vagy ha már létezik beleír), az alábbi sorokat adja hozzá a beállításnak megfelelően:

 

6 Hozzászólás

  • Csabi
    Posted 2020. 04 25. 10:31 0Likes

    Üdv. Ha átállítom a 7.3 – ra akkor http error 500 al megdöglik az oldalam . Állítólag ez a megoldás:
    https://bakemywp.com/wp-content/uploads/2019/03/select_php_version_7.3.jpg
    https://bakemywp.com/update-wordpress-php-7-3-500-internal-server-error/

    Ezt hol találom meg?

  • Mucsi Zoltán
    Posted 2020. 05 20. 18:28 0Likes

    Nálam ugyan ez a helyzet. Az adatbázis 7.3 (ea-php73) van beállítva, de a WP rinyál, hogy 5.6.40 fut.
    Megnyugtató lenne, ha nem volna a figyelmeztetés!

    • Csabi
      Posted 2020. 05 25. 07:56 0Likes

      Ma megnéztem kíváncsiságból… és nincs ott a figyelmeztetés…. valahogy észhez tért …. 🙂 Pedig nem csináltam vele semmit… valami cache ben ragadt dolog lehetett …. passz

  • Csilla
    Posted 2020. 07 21. 14:54 0Likes

    Hello,
    Sajnos nálam is gondot okoz a php frissítés. A honlapomon ellenőriztem a php compatibility-vel és nem jelez pb-át egyik bővítményemnél sem. Ennek ellenére, amint 5.6-os PHP-nál frissebb verziót állítok be a cPanelen eltűnik az oldalam. Mi lehet a gond. Tudna vki segíteni?
    Köszönöm előre is!
    Csilla

Hozzászólás küldése

Ez az oldal az Akismet szolgáltatást használja a spam csökkentésére. Ismerje meg a hozzászólás adatainak feldolgozását .